June 28, 2026 - We are observing a drop in station reachability due to an issue with our partner carrier in EU region. Our teams are investigating the issue

Incident Report for CP Public Status Page

Resolved

Our Partner Carrier has resolved the issue on their end, and all services are now operational.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 29, 2026 - 03:37 UTC

Identified

We are observing a drop in station reachability due to an issue with our partner carrier in EU region. Our teams are investigating the issue
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 28, 2026 - 08:25 UTC
This incident affected: Charging Stations (Station Connectivity).