June 29, 2026 - Drop in Station Reachability

Incident Report for CP Public Status Page

Resolved

Our Partner Carrier has resolved the issue on their end, and all services are now operational.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 30, 2026 - 05:24 UTC

Monitoring

Service recovery is currently in progress. We continue to monitor all services until full restoration is confirmed.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 29, 2026 - 11:43 UTC

Identified

We are observing a drop in station reachability due to an issue with our partner carrier in NA region. Our teams are investigating the issue
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 29, 2026 - 07:15 UTC
This incident affected: Charging Stations (Station Connectivity).