July 4, 2026 - Drop in station reachability in North America region.

Incident Report for CP Public Status Page

Resolved

We have resolved the issue from our end and all services are now operational.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jul 04, 2026 - 17:05 UTC

Monitoring

We have resolved the issue from our end and all services are now operational.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jul 04, 2026 - 17:03 UTC

Update

Our teams continue to investigate the issue, and updates will be provided as and when available.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jul 04, 2026 - 16:17 UTC

Investigating

We have identified an issue with our services. As a result customers may experience degradations while using our charging stations. Our technical teams are activiely investigating the issue.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jul 04, 2026 - 14:09 UTC

Identified

We have identified an issue with our services. As a result customers may experience degradations while using our charging stations. Our technical teams are activiely investigating the issue.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jul 04, 2026 - 12:59 UTC
This incident affected: Charging Stations (Station Connectivity).