All the FALC Stations have connected back to NOS. Teams are closely monitoring for stability of the Station reachability.
Posted Sep 14, 2026 - 11:49 UTC
Update
Almost all of the Stations are recovered. The connection with NOS is re-established.
Posted Sep 14, 2026 - 11:16 UTC
Update
Team have identified Auxilary issues which are being worked on and teams are focusing on restoring the reachability of the impacted Stations at the earliest.
Posted Sep 14, 2026 - 07:52 UTC
Monitoring
A fix has been implemented and we keep monitoring the system
Posted Sep 14, 2026 - 05:00 UTC
Update
Our teams continue to investigate the issue, and updates will be provided as and when available.
Posted Sep 14, 2026 - 01:26 UTC
Identified
We have identified a drop in station connectivity affecting the EU region. As a result customers may experience degradations while using our charging stations. Our technical teams are actively investigating the issue. Services Impacted: - Station Connectivity Impact: major
Posted Sep 14, 2026 - 01:11 UTC
This incident affected: Charging Stations (Station Connectivity).