We have resolved the issue from our end, and all services are now operational. Services Impacted: - Station Connectivity Impact: major
Posted Jul 29, 2026 - 16:08 UTC
Investigating
The issue has reoccurred after the earlier resolution. Our teams continue to investigate the issue, and updates will be provided as and when available. Services Impacted: - Station Connectivity Impact: major
Posted Jul 29, 2026 - 13:37 UTC
Monitoring
The issue has been resolved from our end, and all services are currently operational. Our team is actively monitoring the services to ensure service stability Services Impacted: - Station Connectivity Impact: major
Posted Jul 29, 2026 - 10:28 UTC
Identified
We have identified an issue with our services. As a result customers may experience degradations while using our charging stations. Our technical teams are actively investigating the issue. Services Impacted: - Station Connectivity Impact: major
Posted Jul 29, 2026 - 09:07 UTC
This incident affected: Charging Stations (Station Connectivity).