June 22, 2026 - We are observing a drop in station reachability due to an issue with our partner carriers in NA region.

Incident Report for CP Public Status Page

Resolved

The issue has been resolved by our technical teams and partner carrier. We will continue monitoring to ensure stability.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 22, 2026 - 17:46 UTC

Update

Our teams continue to investigate the issue, and updates will be provided as and when available.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 22, 2026 - 07:06 UTC

Identified

We are observing a drop in station reachability due to an issue with our partner carriers in NA region . Our teams are investigating the issue.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 22, 2026 - 05:59 UTC
This incident affected: Charging Stations (Station Connectivity).