June 10, 2026 - We are observing a drop in station reachability due to an issue with our partner carriers. Our teams are investigating the issue

Incident Report for CP Public Status Page

Resolved

We have resolved the issue from our end and all services are now operational.
Services Impacted:
- Station Connectivity
Impact: critical
Posted Jun 10, 2026 - 08:22 UTC

Investigating

We are observing a drop in station reachability due to an issue with our partner carrier in NA region. Our team continues to investigating the issue.
Services Impacted:
- Station Functionality
Impact: critical
Posted Jun 10, 2026 - 04:57 UTC

Identified

We are observing a drop in station reachability due to an issue with our partner carriers. Our teams are investigating the issue
Services Impacted:
- Station Functionality
Impact: critical
Posted Jun 10, 2026 - 04:44 UTC
This incident affected: Charging Stations (Station Connectivity).