Our partner carrier has resolved the issue on their end, and all services are now operational. Services Impacted: - Station Connectivity Impact: major
Posted Feb 11, 2026 - 18:08 UTC
Update
Drop in station reachability due to an outage with our partner carrier in the FedRAMP and North America regions. Our teams continue to investigate the issue, and updates will be provided as and when available. Services Impacted: - Station Connectivity Impact: major
Posted Feb 11, 2026 - 17:10 UTC
Investigating
We are observing a drop in station reachability due to an outage with our partner carrier in the FedRAMP and North America regions. Our technical teams are actively investigating the issue. Services Impacted:
Impact: major
Posted Feb 11, 2026 - 15:46 UTC
Identified
We are seeing a drop in station reachability due to an outage with our partner carrier in the Europe & North America region, and our teams are looking into it. Services Impacted:
Impact: major
Posted Feb 11, 2026 - 15:32 UTC
This incident affected: Charging Stations (Station Connectivity).