June 18, 2026 - Drop in station reachability in EU region

Incident Report for CP Public Status Page

Resolved

The issue has been resolved by our technical teams and partner carrier. We will continue monitoring to ensure stability.
Services Impacted:
- Station Connectivity
Impact: none
Posted Jun 18, 2026 - 16:18 UTC

Monitoring

The issue has been resolved by our technical teams and partner carrier. We will continue monitoring to ensure stability.
Services Impacted:
- Station Connectivity
Impact: none
Posted Jun 18, 2026 - 15:46 UTC

Update

We have identified an issue with our services. As a result, customers in Europe region may experience degradation while using our charging stations. Our technical teams are actively investigating the issue.
Services Impacted:
- Station Connectivity
Impact: none
Posted Jun 18, 2026 - 13:40 UTC

Identified

We are observing a drop in station reachability in EU region due to an issue with our partner carriers. Our teams are investigating the issue
Services Impacted:
- Station Connectivity
Impact: none
Posted Jun 18, 2026 - 13:17 UTC
This incident affected: Charging Stations (Station Connectivity).